Back to overview
Downtime

Power Outage

Mar 11, 2026 at 11:30pm UTC
Affected services
Spritz Website
Bot Status
Database

Resolved
Mar 13, 2026 at 10:31am UTC

Over the past two evenings, unexpected power outages have occurred, causing our systems to go offline. We apologize for the inconvenience; power has been restored and services are back online.

Incident history:
- March 12: 12:30 AM to 2:30 AM
- March 12-13: 10:30 PM to 1:30 AM

We have already contacted the National Electricity Board twice via fault reporting, seeking a quick resolution. Unfortunately, despite our best efforts, the problem persists, and the support team's handling has been horrendous: during the second report, the call was hung up on us without any response or resolution.

Updated
Mar 13, 2026 at 12:30am UTC

The issue has since been resolved, however the national agency has not released any further information about the incident.

Updated
Mar 12, 2026 at 9:30pm UTC

There was another blackout, we are contacting the responsible authority again.

Updated
Mar 12, 2026 at 1:30am UTC

We contacted the National Electricity Board and they resolved the issue following an operator inspection.

Created
Mar 11, 2026 at 11:30pm UTC

We've noticed a power outage and are contacting the National Electricity Board to resolve the issue.